Back to overview

Cloudflare Network Issue May Cause Intermittent Service Impact

Nov 18 at 08:16am GMT-4
Affected services
Manager
Manager

Resolved
Nov 18 at 11:05am GMT-4

Update

Cloudflare has implemented a fix for the global network issue and reports that mitigation is in progress. They are continuing to monitor the situation.

From our side, all Timus services are operating normally and we are not observing any issues in our infrastructure.

We will continue to closely monitor both Cloudflare and our own systems. If you experience any problems accessing Timus services, please contact our support team / open a support ticket.

Created
Nov 18 at 08:16am GMT-4

Summary

Cloudflare is currently experiencing a global network issue that is causing widespread service disruptions across multiple platforms. As Timus Networks uses Cloudflare as the first line of defense for our cloud services, we want to keep you informed about potential impacts.

Current Status

We are not currently experiencing any service issues. All Timus platform services, gateways, and Timus Connect applications are operating normally. However, due to the ongoing Cloudflare incident, there may be intermittent disruptions until Cloudflare resolves the issue.

About Our Infrastructure

Timus Networks utilizes Cloudflare as the first line of defense for our cloud services, providing DDoS protection, DNS resolution, and content delivery. The current Cloudflare incident may affect these protective layers, though our core infrastructure remains stable.

Cloudflare's Report

According to Cloudflare's status page:

  • Status: Investigating
  • Impact: Widespread 500 errors, Cloudflare Dashboard and API failures
  • Scope: Multiple customers globally affected
  • Last Update: November 18, 2025 - 12:03 UTC

The issue appears to be affecting multiple Cloudflare datacenters, including:

  • ORD (Chicago): 05:00 – 12:00 UTC (Nov 18)
  • ATL (Atlanta): 07:00 UTC (Nov 18) – 22:00 UTC (Nov 19)
  • GUA (Guatemala City): 08:00 – 12:00 UTC (Nov 18)
  • MIA (Miami): 09:00 – 12:00 UTC (Nov 18)
  • LAX (Los Angeles): 10:00 – 14:00 UTC (Nov 18)

What We're Doing

  • Active Monitoring: Our team is closely monitoring Cloudflare's service status and incident updates in real-time
  • Contingency Planning: We are actively working on alternative solutions in case our services experience widespread issues
  • Ready to Act: We have procedures in place to quickly implement backup measures if needed

Important Notes

  • Our external status page (status.timusnetworks.com) is also hosted on Cloudflare and may be intermittently unavailable during this incident
  • If issues persist or escalate, we will switch to email-based communications to keep you updated
  • Any service disruptions you may experience should be temporary and resolve as Cloudflare addresses the issue

What You Might Experience

  • Brief DNS resolution delays
  • Intermittent connectivity to Timus cloud services
  • Temporary inability to access our status page
  • Possible 500 errors when accessing Timus services

Need Help?

If you experience any issues with Timus services, please contact our support team. We're here to help and will work to resolve any problems quickly.

We will continue to monitor the situation closely and provide updates as Cloudflare shares new information.